Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en CX-Supervisor de Omron

Fecha de publicación: 18/10/2018

Importancia: Alta

Recursos afectados:

  • CX-Supervisor versión 3.4.1.0 y anteriores

Descripción:

Los investigadores Mat Powell de Zero Day Initiative de Tend Micro, Ariele Caltabiano de 9SG Security Team y b0nd de @garage4hackers, en colaboración con Zero Day Initiative de Tend Micro han reportado varias vulnerabilidades del tipo restricción incorrecta de operaciones dentro de los límites del búfer de memoria, lectura fuera de límites, uso de recursos después de su liberación y conversión incorrecta de tipos, que afectan al software CX-Supervisor de Omron. Un potencial ataque remoto podría ejecutar código arbitrario en el contexto de la aplicación, corromper objetos o forzar a la aplicación a leer un valor fuera de un array.

Solución:

Omron la lanzado la versión 3.4.2 que soluciona estas vulnerabilidades. Los usuarios la pueden descargar en el siguiente enlace: https://www.myomron.com/index.php?action=kb&article=1709.

Detalle:

  • Incorrecta restricción de operaciones dentro de los límites del búfer de memoria. Un potencial atacante podría manipular un byte específico de los archivos de proyecto y causar una corrupción de memoria en el tratamiento de un objeto específico. Se ha asignado el identificador CVE-2018-17905 para esta vulnerabilidad.
  • Lectura fuera de límites. Un potencial atacante podría manipular los archivos de proyecto para forzar a la aplicación a leer un valor fuera del array. Se ha asignado el identificador CVE-2018-17907 para esta vulnerabilidad.
  • Uso de recursos después de su liberación. Al procesar los archivos de proyecto, la aplicación no es capaz de verificar si se hace referencia a la memoria liberada, esto podría permitir que un atacante ejecute código en el contexto de la aplicación. Se ha asignado el identificador CVE-2018-17909 para esta vulnerabilidad.
  • Conversión incorrecta de tipos. Un potencial atacante podría conseguir la ejecución de código en el contexto de la aplicación aprovechándose de un error de conversión en la lectura de los ficheros de proyecto. Se ha asignado el identificador CVE-2018-17913 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad