Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Desbordamiento de búfer en PMSoft de Delta Electronics

Fecha de publicación: 27/04/2018

Importancia: Alta

Recursos afectados:

  • PMSoft v 2.10 y anteriores

Descripción:

El investigador Ghirmay Desta, trabajando con Zero Day Initiative de Trend Micro, ha informado de varios desbordamientos de búfer que afectan al software PMSoft de Delta Electronics. Un potencial atacante local podría aprovecharse de estas vulnerabilidades para ejecutar código arbitrario o hacer que la aplicación falle.

Solución:

Delta Electronics recomienda a los usuarios afectados actualizar a PMSoft v2.1, que está disponible desde el 22 de marzo de 2018. La descarga puede encontrarse en el siguiente enlace:

www.deltaww.com/Products/PluginWebUserControl/downloadCenterCounter.aspx?DID=2092&DocPath=1&hl=en-US

Detalle:

La aplicación tiene múltiples vulnerabilidades de tipo desbordamiento de búfer donde un fichero .ppm puede introducir un valor más largo que el que permite leer el búfer de tamaño fijo definido en PMSoft. Esto provoca que el búfer se sobrescriba, lo que puede permitir la ejecución de código arbitrario o hacer que la aplicación falle. Se ha reservado el identificador CVE-2018-8839 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad