Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Ejecución remota de código en productos Pepperl Fuchs

Fecha de publicación: 09/07/2018

Importancia: Alta

Recursos afectados:

  • Todos los productos de las familias VisuNet RM, VisuNet PC y Box Thin Client BTC

Descripción:

Los investigadores de seguridad Eyal Karni, Yaron Zinar, Roman Blachman de Preempt y Research Labs han identificado una vulnerabilidad de ejecución remota de código en el protocolo Credential Security Support Provider (CredSSP) de Microsoft. Un potencial atacante podría aprovechar esta vulnerabilidad para retransmitir credenciales de usuario para la ejecución de código arbitrario en el sistema de destino.

Solución:

  • Dispositivos Pepperl Fuchs HMI ejecutando RM Shell 4 deberían actualizar a RM Image 4 Security Patches 01/2017 a 05/2018 (18-33400C).
  • Dispositivos Pepperl Fuchs HMI ejecutando RM Shell 5 deberían actualizar a RM Image 5 Security: Windows Cumulative Security Patch 07/2018 (18-33624).
  • Dispositivos Pepperl Fuchs HMI ejecutando Windows 7 o Windows 10 deberían actualizar usando el mecanismo de actualización de Windows Update.
  • Después de desplegar el parche, todos los clientes o servidores de terceros conectados deben usar la última versión del protocolo CredSSP.

Detalle:

Un potencial atacante podría ejecutar código arbitrario y obtener acceso a datos sensibles interceptando la conexión RDP inicial entre un cliente y un servidor remoto. Se require de un ataque MitM para controlar la sesión. Se ha reservado el identificador CVE-2018-0886 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad