Configuración de Cookies

Cookies técnicas

Activas
ver cookies

Son aquellas que permiten al usuario la navegación a través de la página web y la utilización de las diferentes opciones o servicios que en ella existan, incluyendo aquellas que el editor utiliza para permitir la gestión y operativa de la página web y habilitar sus funciones y servicios.

Cookies analíticas

Inactivas
ver cookies

Son aquellas que permiten al responsable de las mismas el seguimiento y análisis del comportamiento de los usuarios del sitio web. La información recogida mediante este tipo de cookies se utiliza en la medición de la actividad del sitio web, con el fin de introducir mejoras en función del análisis de los datos de uso que hacen los usuarios del servicio.

AVISO DE COOKIES

Esta página web, propiedad de SPRI, utiliza cookies propias y de terceros con la finalidad de permitir su navegación, elaborar información estadística, analizar sus hábitos de navegación y remitirle publicidad en función de los mismos. Puedes hacer clic en Aceptar para permitir el uso de todas las cookies o puedes elegir qué tipo de cookies deseas aceptar o rechazar mediante la opción Configurar Cookies. También, puedes obtener más información en nuestra Política de Cookies.Configurar cookiesAceptar

Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Gestión inadecuada de privilegios en productos Codesys V3

Fecha de publicación: 07/05/2020

Importancia: Media

Recursos afectados:

  • Todas las versiones del sistema de desarrollo CODESYS V3 anteriores a la V3.5.16.0, tanto para 32, como para 64 bits;
  • Los siguientes productos en versiones anteriores a la V3.5.16.0:
    • CODESYS Control para BeagleBone,
    • CODESYS Control para emPC-A/iMX6,
    • CODESYS Control para IOT2000,
    • CODESYS Control para Linux,
    • CODESYS Control para PLCnext,
    • CODESYS Control para PFC100,
    • CODESYS Control para PFC200,
    • CODESYS Control para Raspberry Pi,
    • CODESYS Control RTE V3,
    • CODESYS Control RTE V3 (para Beckhoff CX),
    • CODESYS Control Win V3 (como parte de la configuración CODESYS Development System),
    • CODESYS HMI V3,
    • CODESYS Control V3 Runtime System Toolkit.

Descripción:

Se ha publicado una vulnerabilidad del tipo gestión inadecuada de privilegios en el sistema de desarrollo CODESYS V3 que podría permitir a un atacante la escalada de privilegios.

Solución:

Para todos los productos afectados, actualizar a la versión V3.5.16.0

Detalle:

CODESYS proporciona varias variantes que pueden ser utilizadas para mostrar la visualización de pantallas. Mediante la función de gestión de usuarios, es posible restringir el acceso a partes concretas de la visualización para ciertos operadores. CODESYS WebVisu y CODESYS Remote TargetVisu son susceptibles de una escalada de privilegios permitiendo el acceso a pantallas de visualización que están destinadas únicamente a operadores específicos. Este ataque es sólo posible bajo una de las siguientes circunstancias:

  • Cuando la navegación de la visualización descargada se realiza seleccionando todas las pantallas de visualización y sólo los elementos para la navegación están protegidos por la gestión de usuarios.
  • Cuando la visualización descargada contiene pantallas de visualización que no pueden ser alcanzadas por la navegación. Como la vulnerabilidad afecta a la propia característica de visualización, los productos de tiempo de ejecución de CODESYS Control sólo se ven afectados si se utiliza la característica de visualización.

Se ha reservado el identificador CVE-2020-12068 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad