Configuración de Cookies

Cookies técnicas

Activas
ver cookies

Son aquellas que permiten al usuario la navegación a través de la página web y la utilización de las diferentes opciones o servicios que en ella existan, incluyendo aquellas que el editor utiliza para permitir la gestión y operativa de la página web y habilitar sus funciones y servicios.

Cookies analíticas

Inactivas
ver cookies

Son aquellas que permiten al responsable de las mismas el seguimiento y análisis del comportamiento de los usuarios del sitio web. La información recogida mediante este tipo de cookies se utiliza en la medición de la actividad del sitio web, con el fin de introducir mejoras en función del análisis de los datos de uso que hacen los usuarios del servicio.

AVISO DE COOKIES

Esta página web, propiedad de SPRI, utiliza cookies propias y de terceros con la finalidad de permitir su navegación, elaborar información estadística, analizar sus hábitos de navegación y remitirle publicidad en función de los mismos. Puedes hacer clic en Aceptar para permitir el uso de todas las cookies o puedes elegir qué tipo de cookies deseas aceptar o rechazar mediante la opción Configurar Cookies. También, puedes obtener más información en nuestra Política de Cookies.Configurar cookiesAceptar

Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en AXC F 2152 de Phoenix Contact

Fecha de publicación: 24/04/2019

Importancia: Alta

Recursos afectados:

  • AXC F 2152 y Starterkit AXC F 2152, versión de firmware 1.x

Descripción:

El investigador Zahra Khani, de Firmalyzer SPRL, y OPC Foundation han publicado múltiples vulnerabilidades que afectan a los dispositivos AXC F 2152 de Phoenix Contact. La explotación exitosa de estas vulnerabilidades podría afectar a la confidencialidad, la integridad o la disponibilidad del dispositivo.

Solución:

  • Phoenix Contact recomienda actualizar los dispositivos a la versión de Firmware y de PLCnext Engineer 2019.0 LTS o posterior para solucionar estas vulnerabilidades.
  • Adicionalmente, para la vulnerabilidad cuyo identificador es CVE-2018-7559, Phoenix Contact recomienda deshabilitar la política de seguridad Basic128Rsa15 en la configuración de los servidores OPC y utilizar siempre Basic256 o superior.

Detalle:

  • La versión de firmware 1.x del dispositivo AXC F 2152 hace uso de versiones antiguas de software de terceros que son vulnerables. El listado de identificadores de dichas vulnerabilidades es el siguiente: CVE-2016-6301, CVE-2017-11108, CVE-2017-11541, CVE-2017-11542, CVE-2017-11543, CVE-2017-15906, CVE-2016-1247, CVE-2018-1000117, CVE-2017-9233, CVE-2017-3735, CVE-2017-3731, CVE-2017-3738, CVE-2017-3737, CVE-2018-0737, CVE-2016-9840, CVE-2016-9841, CVE-2016-9842, CVE-2016-9843, CVE-2018-1000122, CVE-2018-1000301, CVE-2017-8817, CVE-2018-1000120, CVE-2018-1000121, CVE-2016-9952, CVE-2016-9953, CVE-2017-1000101, CVE-2017-8816, CVE-2017-1000254, CVE-2017-1000100, CVE-2017-1000257, CVE-2018-1000005, CVE-2016-7141, CVE-2017-5334, CVE-2017-5335, CVE-2017-5336, CVE-2017-5337, CVE-2016-7444, CVE-2017-9023, CVE-2018-5388, CVE-2017-9022, CVE-2017-11185, CVE-2015-9251, CVE-2016-7103.
  • Un atacante remoto podría realizar un man in the middle y causar una denegación de servicio en el protocolo de fuzzing de PC WORX Engineer, deteniendo el servicio del PLC. Para restablecer el servicio se debe reiniciar el dispositivo o restablecerlo manualmente mediante la consola Linux. Se ha reservado el identificador CVE-2019-10997 para esta vulnerabilidad.
  • Un atacante con acceso físico al dispositivo podría extraer la tarjeta SD y manipular sus datos, lo que permitiría evitar la autenticación del dispositivo. Se ha reservado el identificador CVE-2019-10998 para esta vulnerabilidad.
  • Un atacante remoto podría aprovechar una vulnerabilidad en la política de seguridad Basic128Rsa15 del servidor OPC enviando tokens de identificación de usuario especialmente diseñados. Esto permitiría al atacante descifrar contraseñas de políticas más robustas como Basic256Sha256. Se ha asignado el identificador CVE-2018-7559 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad