Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en LAquis SCADA de LCDS

Fecha de publicación: 17/10/2018

Importancia: Alta

Recursos afectados:

  • LAquis SCADA Smart Security Manager, versión 4.1.0.3870 y anteriores.

Descripción:

El investigador Mat Powell de Zero Day Initiative (Trend Micro), rgod de 9SG Security Team, Esteban Ruiz de Source Incite, b0nd de @garage4hackers y Ashraf Alharbi en colaboración con Zero Day Initiative, han reportado varias vulnerabilidades de tipo desbordamiento de búfer, escritura y lectura fuera de límites, desreferencia de puntero no confiable y control incorrecto a rutas de directorios restringidos (Path traversal). Con la ejecución exitosa de estas vulnerabilidades, un atacante remoto podría ejecutar código arbitrario, escribir contenido en el sistema de destino o bloquear el sistema.

Solución:

LCDS propone a los usuarios actualizar a la versión 4.1.0.4114

Detalle:

  • Una vulnerabilidad de desreferencia de puntero no confiable podría permitir la ejecución de código de manera remota. Se ha asignado el identificador CVE-2018-17893 para esta vulnerabilidad.
  • Se ha identificado una vulnerabilidad de lectura fuera de límites, que podría permitir a un atacante remoto ejecutar código en los productos afectados. Se ha asignado el identificador CVE-2018-17895 para esta vulnerabilidad.
  • Vulnerabilidad de desbordamiento de búfer permitiría a un potencial atacante remoto la ejecución de código. Se ha asignado el identificador CVE-2018-17897para esta vulnerabilidad.
  • Control incorrecto a rutas de directorios restringidos (path traversal) que podría permitir a un atacante la ejecución remota de código. Se ha asignado el identificador CVE-2018-17899 para esta vulnerabilidad.
  • Cuando se procesan los archivos de proyecto, la aplicación falla al validar los datos de entrada del usuario antes de realizar operaciones de escritura en un objeto de la pila. Este hecho, podría permitir a un atacante la ejecución de código en el proceso actual que se está ejecutando. Se ha asignado el identificador CVE-2018-17901 para esta vulnerabilidad.
  • Se han identificado varias vulnerabilidades de desbordamiento de búfer que podrían permitir a un atacante la ejecución remota de código. Se ha asignado el identificador CVE-2018-17911 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad