Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en CompactLogix y GuardLogix de Rockwell Automation

Fecha de publicación: 02/05/2019

Importancia: Alta

Recursos afectados:

  • Controladores CompactLogix 5370 L1 versiones de la 20 a la 30.014 y anteriores;
  • Controladores CompactLogix 5370 L2 versiones de la 20 a la 30.014 y anteriores;
  • Controladores CompactLogix 5370 L3 versiones de la 20 a la 30.014 y anteriores;
  • Controladores Compact GuardLogix 5370 versiones de la 20 a la 30.014 y anteriores;
  • Controladores Armor Compact GuardLogix 5370 versiones de la 20 a la 30.014 y anteriores.

Descripción:

Los investigadores, Younes Dragoni de Nozomi Networks y George Lashenko de CyberX, han reportado vulnerabilidades de tipo control inadecuado de recursos y desbordamiento de búfer, en los productos CompactLogix y GuardLogix de Rockwell Automation. La explotación exitosa de estas vulnerabilidades permitiría a un atacante remoto provocar una denegación de servicio del servidor web o provocar una falta no recuperable en los dispositivos (MNRF, del inglés Major Non-Recoverable Fault).

Solución:

  • Rockwell Automation recomienda encarecidamente a los usuarios aplicar los últimos parches disponibles a los dispositivos, para estar al día con las últimas funcionalidades, corrección de errores y mejoras de seguridad. Actualizar a la versión de firmware FRN 31.011 o posteriores, mitiga los riesgos asociados a estas vulnerabilidades.

Detalle:

  • Control inadecuado de recursos: un atacante remoto, puede enviar un paquete HTTP/HTTPS, especialmente diseñado, que aproveche una vulnerabilidad de desbordamiento de búfer, provocando la posibilidad de ejecutar código de forma remota o dejar el servidor no disponible. Sería necesario un reinicio forzado, cold restart,para recuperar el sistema. Se ha asignado el identificador CVE-2019-10952 para esta vulnerabilidad.
  • Desbordamiento de búfer: un atacante remoto, puede enviar un paquete SNMP especialmente diseñado, para provocar una denegación de servicio que dejaría al controlador en un estado de falta mayor no recuperable (MNRF). Se ha asignado el identificador CVE-2019-10954 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad