Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en comunicadores de GE

Fecha de publicación: 03/05/2019

Importancia: Alta

Recursos afectados:

  • Communicator Installer, Application, PostGreSQL, MeterManager y WISE Uninstaller, versiones anteriores a la 4.0.517.

Descripción:

El investigador Reid Wightman de Dragos ha reportado varias vulnerabilidades de tipo: ruta de búsqueda no controlada, uso de credenciales embebidas y control de acceso incorrecto. Un potencial atacante podría obtener permisos de administrador, manipular widgets e interfaces de usuario, obtener el control de la base de datos o ejecutar comandos reservados para administración.

Solución:

Detalle:

  • Un atacante sin permisos administrativos podría colocar archivos maliciosos en el directorio de archivos del instalador para obtener privilegios administrativos en un sistema durante la instalación o la actualización. Se ha reservado el identificador CVE-2019-6564 para esta vulnerabilidad.
  • Un atacante podría colocar archivos maliciosos en el directorio de trabajo del programa para manipular widgets y elementos de la interfaz de usuario. Se ha reservado el identificador CVE-2019-6546 para esta vulnerabilidad.
  • Existen dos cuentas de usuarios, consideradas backdoors, que podrían permitir el control sobre la base de datos por parte de un atacante. Este servicio es inaccesible para un atacante si la víctima usa la configuración predeterminada del cortafuegos de Windows. Se ha reservado el identificador CVE-2019-6548 para esta vulnerabilidad.
  • Un servicio ejecutado con permisos del sistema, podría permitir a un atacante sin permisos realizar ciertas acciones administrativas, lo que puede permitir la ejecución de scripts programados con privilegios de administrador en el sistema. Este servicio es inaccesible para los atacantes si el usuario víctima usa la configuración predeterminada del cortafuegos de Windows. Se ha reservado el identificador CVE-2019-6544 para esta vulnerabilidad.
  • Un atacante sin permisos de administración puede reemplazar el desinstalador con una versión maliciosa para obtener privilegios de administrador en el sistema. Se ha reservado el identificador CVE-2019-6566 para esta vulnerabilidad

Etiquetas: Actualización, Vulnerabilidad