Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en PLC Editor de Wecon

Fecha de publicación: 18/09/2018

Importancia: Media

Recursos afectados:

  • PLC Editor todas las versiones.

Descripción:

El investigador Natnael Samson (Natti) de Zero Day Initiative ha reportado estas vulnerabilidades de tipo desbordamiento de búfer. La explotación exitosa de estas vulnerabilidades permitiría a un atacante la ejecución de código remoto en el producto afectado.

Solución:

Dada la naturaleza de la vulnerabilidad, la única medida de mitigación posible es restringir la interacción de la aplicación sólo entre ficheros confiables.

Detalle:

  • Dos vulnerabilidades de desbordamiento de búfer podrían permitir a un atacante la ejecución de código remoto en la instalación del software Wecon PLC Editor. Se requiere la interacción del usuario para explotar esta vulnerabilidad ya que debe visitar una página o abrir un archivo malicioso. El problema radica dentro de los archivos WCP. Al analizar el elemento projectVersion o el DevCmt, el proceso no valida correctamente la longitud de los datos proporcionados por el usuario antes de copiarlo en el búfer de tamaño fijo. El atacante puede aprovechar esta vulnerabilidad para ejecutar código en el proceso actual.

Etiquetas: 0day, Vulnerabilidad