Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en IntelliSpace Cardiovascular de Philips

Fecha de publicación: 16/08/2018

Importancia: Alta

Recursos afectados:

  • IntelliSpace Cardiovascular (ISCV), versiones 3.1 y anteriores.
  • Xcelera versiones 4.1 y anteriores.

Descripción:

Philips ha reportado varias vulnerabilidades en sus productos de gestión de información IntelliSpace Cardiovascular (ISCV). Un potencial atacante con acceso local y autenticado en la aplicación, podría aprovecharse de estas vulnerabilidades para escalar privilegios dentro del servidor ISCV/Xcelera o ejecutar código arbitrario.

Solución:

  • Una de las vulnerabilidades publicadas que aplica a las versiones ISCV versión 2.X y anteriores, es corregida en la versión 3.1, los usuarios pueden ponerse en contacto con el equipo de soporte de Philips para su actualización.
  • Para la vulnerabilidad sobre la versión 3.1 y anteriores y Xcelera versiones 4.1 y anteriores, se espera para octubre del 2018 una actualización que la resuelva.
  • Como medida de mitigación mientras la nueva versión 3.2 pueda ser aplicada, Philips recomienda a los usuarios:
    • Revisar las políticas de accesos y permisos sobre los ficheros, restringiendo en la medida de lo posible dichos permisos.

Detalle:

  • Gestión de privilegios inapropiada: En ISCV versión 2.X y anteriores y Xcelera 4.X y 3.X y anteriores, los servidores contienen una serie de servicios cuyos ejecutables son accesibles por un usuario autenticado y son arrancados con permisos elevados. Si un atacante local autenticado reemplazara uno de estos ejecutables por un programa malicioso, este también se ejecutaría con privilegios elevados. Se ha reservado el identificador CVE-2018-14787 para esta vulnerabilidad.
  • Ausencia de comillas en un elemento o directorio de búsqueda: En ISCV versiones 3.X y anteriores y Xcelera 4.X y anteriores, existen una serie de servicios Windows corriendo con privilegios elevados, estos servicios no disponen de comillas en su definición de directorio, lo que permite a un posible atacante reemplazar estos servicios por otros ejecutables. Se ha reservado el identificador CVE-2018-14789 para esta vulnerabilidad.

Etiquetas: Vulnerabilidad