Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en iSite e IntelliSpace PACS de Philips

Fecha de publicación: 02/04/2018

Importancia: Alta

Recursos afectados:

Todas las versiones de iSite e IntelliSpace PACS.

Descripción:

Philips ha publicado una serie de vulnerabilidades con dificultad de explotación baja que podrían permitir que un atacante envíe entradas inesperadas en la aplicación, ejecute código arbitrario, altere el flujo de control del sistema, acceda a información sensible o cause un cierre inesperado del sistema, comprometiendo la confidencialidad del paciente, la integridad del sistema y/o la disponibilidad del mismo.

Solución:

Philips IntelliSpace PACS se ejecuta en un entorno controlado que minimiza el riesgo (utilizando VPN, en una red aislada mediante firewall y sin acceso a internet). Además, Philips cuenta con un antivirus que monitoriza y gestiona las amenazas en sus sistemas.

Como medidas de prevención, Philips recomienda:

  • Inscribirse en el programa de parcheo recurrente de Philips
  • Actualizar el firmware del sistema
  • Actualizar a IntelliSpace PACS 4.4.55x con el sistema operativo Windows 2012

También pone a disposición de sus usuarios un servicio de atención al cliente donde poder realizar sus consultas, disponible en:

Detalle:

Las vulnerabilidades que afectan a los productos afectados son:

  • Restricción indebida de operaciones en los límites de un búfer de memoria que podría causar que las operaciones de lectura y escritura se realizaran en ubicaciones de memoria asociadas a otras variables, estructuras de datos o datos internos del programa, permitiendo la ejecución de código arbitrario, la alteración del flujo de control previsto, la lectura de información confidencial o el cierre inesperado del sistema.
  • Múltiples vulnerabilidades en el código/código fuente presentes desde el desarrollo o la integración de componentes de terceros.
  • Exposición de información que permitiría a un atacante la lectura o la divulgación no autorizada de información confidencial.
  • Vulnerabilidad de control inapropiado de generación de código (inyección de código) que podría permitir la ejecución de instrucciones o códigos no autorizados.
  • Debilidades de la lista top ten de OWASP que podrían permitir el acceso a recursos no autorizados o la ejecución de instrucciones o códigos no autorizados.
  • Analizador XML incorrectamente restringido que podría permitir que el sistema leyera un archivo local y realizara solicitudes a servidores a los que el atacante no podría acceder normalmente, evitando restricciones del firewall u ocultando el origen de los ataques tales como el escaneo de puertos.
  • Vulnerabilidades en componentes de terceros que podrían causar denegación del servicio, ejecución de código arbitrario, inyección de paquetes de red, obtención de información confidencial y/o la obtención de privilegios no autorizados afectando a la confidencialidad, integridad o disponibilidad del sistema.

Etiquetas: Privacidad, Vulnerabilidad