Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en productos CODESYS de 3S-Smart Software Solutions GmbH

Fecha de publicación: 14/11/2018

Importancia: Alta

Recursos afectados:

Todas las variantes de los siguientes productos CODESYS V3 en todas las versiones anteriores a la V3.5.13.20 que contienen el componente CmpTraceMgr se ven afectados, independientemente del tipo de CPU o sistema operativo:

  • CODESYS Control para BeagleBone.
  • CODESYS Control para emPC-A/iMX6.
  • CODESYS Control para IOT2000.
  • CODESYS Control para Linux.
  • CODESYS Control para PFC100.
  • CODESYS Control para PFC200.
  • CODESYS Control para Raspberry Pi.
  • CODESYS Control RTE V3.
  • CODESYS Control RTE V3 (para Beckhoff CX).
  • CODESYS Control Win V3 (también parte de la configuración de CODESYS Development System).
  • CODESYS V3 Simulation Runtime (parte del CODESYS Development System).
  • CODESYS Control V3 Runtime System Toolkit.

El componente CmpOpenSSL se lanzó inicialmente con la versión V3.5.5.0. En general, todos los sistemas de tiempo de ejecución de CODESYS V3 anteriores a la versión V3.5.13.20, que contengan el componente CmpOpenSSL y que se ejecuten sobre uno de los siguientes sistemas operativos se ven afectados:

  • Linux
  • WindowsCE

Todas las variantes de los siguientes productos CODESYS V3 en todas las versiones anteriores a la V3.5.13.30 que contienen el componente CmpBlkDrvTcp se ven afectados, independientemente del tipo de CPU o sistema operativo:

  • Todos los que afectaban al componente CmpTraceMgr, salvo CODESYS V3 Simulation Runtime (parte del CODESYS Development System).
  • CODESYS V3 Embedded Target Visu Toolkit.
  • CODESYS V3 Remote Target Visu Toolkit.
  • CODESYS V3 Safety SIL2.
  • CODESYS Gateway V3.
  • CODESYS HMI V3.
  • CODESYS OPC Server V3.
  • CODESYS PLCHandler SDK.
  • CODESYS Development System V3.

Descripción:

Los investigadores de ABB Switzerland Ltd., Jérôme Vialle de Schneider Electric y los clientes OEM del producto CODESYS, han reportado varias vulnerabilidades de denegación de servicio. Un potencial atacante remoto podría aprovechar estas vulnerabilidades, causando una falta de disponibilidad de los productos afectados.

Solución:

3S-Smart Software Solutions GmbH ha publicado nuevas versiones (V3.5.12.70 y V3.5.13.20) para solventar las vulnerabilidades que afectan a los productos de CODESYS, que pueden obtenerse desde su centro de descarga.

Detalle:

  • El envío de una petición especialmente diseñada en las comunicaciones del producto afectado, podría permitir a un atacante remoto un acceso no permitido en CODESYS, provocando la denegación de servicio.
  • Un atacante remoto podría crear peticiones TLS para impedir que los clientes puedan comunicarse con los servidores mediante el uso del componente CmOpenSSL de CODESYS Control runtime system, provocando la denegación del servicio.
  • El envío de paquetes TCP especialmente diseñados podría permitir a un atacante remoto bloquear las comunicaciones entre clientes TCP de CODESYS y CODESYS Control runtime system, provocando la denegación del servicio.

Etiquetas: Comunicaciones, Vulnerabilidad