Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en productos de Siemens

Fecha de publicación: 08/08/2018

Importancia: Alta

Recursos afectados:

  • Automation License Manager 5, todas las versiones anteriores a la 5.3.4.4.
  • Automation License Manager 6, todas las versiones anteriores a la 6.0.1 (sólo afectado por la vulnerabilidad CVE-2018-11455).
  • SIMATIC STEP 7 (TIA Portal) y WinCC (TIA Portal) V10, V11, V12, todas las versiones.
  • SIMATIC STEP 7 (TIA Portal) y WinCC (TIA Portal) V13, todas las versiones.
  • SIMATIC STEP 7 (TIA Portal) y WinCC (TIA Portal) V14, todas las versiones anteriores a la V14 SP1 Update 6.
  • SIMATIC STEP 7 (TIA Portal) y WinCC (TIA Portal) V15, todas las versiones anteriores a la V15 Update 2.
  • MindConnect IoT2040, todas las versiones anteriores a la V03.01.
  • MindConnect Nano (IPC227D), todas las versiones anteriores a la V03.01.
  • SIMATIC ET 200SP Open Controller CPU 1515SP PC (OC1), todas las versiones anteriores a la V2.1.
  • SIMATIC HMI WinCC Flexible, todas las versiones.
  • SIMATIC IPC DiagBase, todas las versiones.
  • SIMATIC IPC DiagMonitor, todas las versiones.
  • SIMATIC S7-1200, todas las versiones.
  • SIMATIC S7-1500, todas las versiones anteriores a la V2.5.2.
  • SIMATIC S7-1500 Software Controller, todas las versiones.
  • SIMATIC WinCC OA V3.14, todas las versiones.
  • SIMATIC WinCC OA V3.15, todas las versiones.
  • SIMATIC WinCC OA V3.16, todas las versiones.
  • SINUMERIK Integrate Access MyMachine service engineer client, como parte de la suite Sinumerik Integrate Product, afectada la versión V4.1.7 y anteriores.
  • SINUMERIK Integrate Operate Client, como parte de la suite Sinumerik Integrate Product, versiones 2.0.11/3.0.11 y todas las anteriores a ellas.

Descripción:

Los investigadores Vladimir Dashchenko de Kaspersky Lab, Younes Dragoni de Nozomi Networks, el equipo del ICS-CERT y Siemens, han participado en el descubrimiento y gestión de varias vulnerabilidades de tipo salto de directorio, gestión inapropiada de permisos, envío de paquetes especialmente diseñados y problemas relacionados con OpenSSL. La vulnerabilidad relacionada con el OpenSSL permitiría a un atacante remoto obtener la información intercambiada bajo un canal ?seguro? con OpenSSL comprometiendo la confidencialidad. Por otro lado, un atacante podría llegar a ejecutar código remoto o modificar la estructura de carpetas en los dispositivos afectados mediante la explotación de las dos vulnerabilidades remanentes.

Solución:

En el caso de los siguientes productos, hay disponible un nueva versión de software que mitiga las vulnerabilidades:

  • Automation License Manager 5, actualizar a V5.3.4.4.
  • Automation License Manager 6, actualizar a V6.0.1.

En el caso de no poder actualizar el producto afectado, el fabricante recomienda restringir el acceso a la red desde la que se puede acceder al sistema que contenga este software.

  • SIMATIC STEP 7 (TIA Portal) y WinCC (TIA Portal) V14, actualizar a la V14 SP1 Update 6.
  • SIMATIC STEP 7 (TIA Portal) y WinCC (TIA Portal) V15, actualizar a la V15 Update 2 o versiones posteriores.
  • Para las versiones 10, 11, 12 y 13 de SIMATIC STEP 7 (TIA Portal) y WinCC (TIA Portal) afectadas el fabricante recomienda aplicar las siguientes mitigaciones:
    • Restringir el acceso al sistema operativo sólo a personas autorizadas.
    • Validar los ficheros GSD para verificar su legitimidad y procesar los ficheros GSD sólo de fuentes confiables.
  • MindConnect IoT2040, actualizar a la V03.01 o posteriores con el Mindsphere web frontend.
  • MindConnect Nano (IPC227D), actualizar a la V03.01 o posteriores con el Mindsphere web frontend.
  • SIMATIC S7-1500, actualizar a la V2.5.2.
  • SINUMERIK Integrate Access MyMachine service engineer client, actualizar a la V4.1.8, instalando la última versión de la suite Sinumerik Integrate Product.
  • SINUMERIK Integrate Operate Client, actualizar a la V2.0.12/3.0.12, instalando la última versión de la suite Sinumerik Integrate Product.
  • S7-1200. El fabricante recomienda deshabilitar el servidor web si este no se está utilizando o limitar el acceso al mismo vía Ethernet/PROFINET puerto/interfaz si es posible. Las configuraciones pueden hacerse en ?General/Web server access?.
  • Para todos los productos a los que no se ha hecho referencia aún en las mitigaciones, el fabricante recomienda restringir el acceso a los productos afectados utilizando mecanismos apropiados como por ejemplo la configuración de un cortafuegos.

Detalle:

  • Salto de directorio (Automation License Manager). La explotación exitosa de esta vulnerabilidad, permitiría a un atacante mover archivos de forma arbitraria, pudiendo llegar a realizar una ejecución remota de código comprometiendo la confidencialidad, integridad y disponibilidad del sistema. La explotación de esta vulnerabilidad requiere que el atacante se encuentre en la misma red que el producto afectado sin necesidad de privilegios o condiciones especiales del sistema, pero, siendo necesaria la interacción de un usuario víctima. Se ha asignado el identificador CVE-2018-11455 para esta vulnerabilidad.
  • Envío de paquetes especialmente diseñados (Automation License Manager). Un atacante con acceso a la red donde se encuentra el producto afectado podría enviar paquetes especialmente diseñados para determinar si es posible acceder o no a un puerto de red en otro sistema remoto. Este hecho permite a un atacante realizar un escaneo de red básico usando una máquina víctima para obtener información. Para explotar esta vulnerabilidad, el atacante ha de estar conectado a la misma red que el producto afectado, no necesita privilegios y no requiere de interacción de usuarios. Se ha asignado el identificador CVE-2018-11456 para esta vulnerabilidad.
  • Gestión de permisos inapropiada. Los permisos que poseen algunos archivos en la instalación por defecto del TIA Portal pueden permitir a un posible atacante con acceso local al sistema insertar archivos especialmente diseñados que pueden evitar el inicio del TIA Portal originando así una denegación de servicio o la ejecución local de código malicioso. Para la explotación exitosa de esta vulnerabilidad no se requieren permisos especiales, pero sí que la víctima intente iniciar el TIA Portal tras la manipulación de los archivos. Se ha asignado el identificador CVE-2018-11453 para esta vulnerabilidad.
  • Gestión de permisos inapropiada. Los permisos que poseen algunos archivos en la instalación por defecto del TIA Portal pueden permitir a un posible atacante con acceso local al sistema manipular recursos que pueden ser transferidos a otros dispositivos y posteriormente ser ejecutados. Para la explotación exitosa de esta vulnerabilidad no se requieren permisos especiales, pero sí que la víctima transfiera los archivos manipulados a otro dispositivo (PG). Se ha asignado el identificador CVE-2018-11454 para esta vulnerabilidad.
  • OpenSSL. En OpenSSL v1.0.2 se introdujo un mecanismo de ?error state?. Este mecanismo no funciona de forma correcta cuando se llama a las funciones SSL_red() o SSL_write(). Este hecho podría resultar en un envío de datos sin cifrado en la capa SSL/TLS. La explotación exitosa de esta vulnerabilidad requiere que un atacante cause un error durante el establecimiento de la conexión (handshake) bajo SSL/TLS y que la aplicación haga las llamadas a SSL_read() o SSL_write() después de recibir el error. No se requieren de privilegios o interacción del usuario para explotar esta vulnerabilidad. Se ha asignado el identificador CVE-2017-3737 para esta vulnerabilidad.

Etiquetas: Navegador, Privacidad, Siemens, Vulnerabilidad