Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en productos de Silex Technology y GE Healthcare

Fecha de publicación: 09/05/2018

Importancia: Alta

Recursos afectados:

  • GEH-500 Versión 1.54 y anteriores
  • SX-500 todas las versiones. (Discontinuado desde 2011)
  • GEH-SD-320AN versión GEH-1.1 y anteriores
  • SD-320AN versión 2.01 y anteriores. (Discontinuada desde noviembre de 2017)
  • GE MAC Resting ECG Modelo MAC 3500
  • GE MAC Resting ECG Modelo MAC 5000. (Discontinuado desde 2012)
  • GE MAC Resting ECG Modelo MAC 5500
  • GE MAC Resting ECG Modelo MAC 5500 HD

Descripción:

El investigador Eric Evenchick de Atredis Partners ha identificado múltiples vulnerabilidades que afectan a los productos de Silex Technology y GE Healthcare. Un potencial atacante remoto, podría explotar estas vulnerabilidades para modificar las configuraciones del sistema o ejecutar código de forma remota.

Solución:

Silex Technology y GE Healthcare recomiendan las siguientes mitigaciones:

  • CVE-2018-6020 (GE MobileLink/SX-500): Habilitar la cuenta ?Update?, en la interfaz web, que viene deshabilitada por defecto. Configurar una segunda contraseña en dicha cuenta ?Update?, para prevenir la realización de cambios de configuración, sin autenticar, en el dispositivo.
  • CVE-2018-6021 (GE MobileLink/GEH-SD-320AN): Silex Technology y GE Healthcare han desarrollado una actualización para solucionar la vulnerabilidad, que será descargable, una vez testeada, a partir del 31 de mayo del 2018.

Detalle:

  • Autenticación Incorrecta: La autenticación en el sistema no es verificada de manera correcta para ciertas peticiones POST, esto permitiría a un atacante modificar ciertas configuraciones del sistema. Se ha asignado el código CVE-2018-6020 para esta vulnerabilidad.
  • Validación incorrecta de parámetros en las llamadas a sistema: Los parámetros utilizados en llamadas a Sistema, no son correctamente sanitizados, lo que permitiría a un posible atacante la ejecución de código inyectando comandos en estos parámetros. Se ha asignado el código CVE-2018-6021 para esta vulnerabilidad

Etiquetas: Vulnerabilidad