Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en CX-Supervisor de Omron

Fecha de publicación: 18/01/2019

Importancia: Alta

Recursos afectados:

  • CX-Supervisor, versiones v3.42 y anteriores

Descripción:

Esteban Ruiz de Source Incite, trabajando con Zero Day Initiative de Trend Micro, ha identificado varias vulnerabilidades que afectan a CX-Supervisor de Omron. Un atacante podría ejecutar comandos con los privilegios en el contexto de la aplicación.

Solución:

  • Omron ha publicado la versión 3.5.0.11 de CX-Supervisor que soluciona estas vulnerabilidades. Para protegerse adecuadamente, los proyectos de desarrollo deben ser actualizados y guardados en el nuevo formato, para posteriormente reconstruirlos en el formato de la versión 3.5.0.11

Detalle:

  • La aplicación puede ejecutar código que haya sido inyectado en un archivo de proyecto. Un atacante podría explotar esta vulnerabilidad para ejecutar código con los privilegios de la aplicación. Se le ha asignado el identificador CVE-2018-19011.
  • Un atacante podría crear un fichero de proyecto especialmente modificado con comandos inyectados para borrar y/o modificar archivos en el dispositivo. Se ha asignado el identificador CVE-2018-19013 para esta vulnerabilidad.
  • Un atacante podría inyectar comandos para lanzar programas, crear, escribir y leer archivos en el dispositivo mediante un fichero de proyecto especialmente modificado. Se ha asignado el identificador CVE-2018-19015 para esta vulnerabilidad.
  • Un atacante podría utilizar un fichero de proyecto especialmente modificado, para aprovecharse de un fallo en la verificación de liberación de la memoria de la aplicación, y de este modo ejecutar código con los privilegios de la aplicación. Se ha asignado el identificador CVE-2018-19017 para esta vulnerabilidad.
  • Un atacante podría utilizar un fichero de proyecto especialmente modificado y aprovecharse de varias confusiones de tipo para explotar y ejecutar código con los privilegios de la aplicación. Se ha asignado el identificador CVE-2018-19011 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad