Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Reutilización de Nonce en dispositivos de BD Pyxis

Fecha de publicación: 25/04/2018

Importancia: Media

Recursos afectados:

  • BD Pyxis Anesthesia ES,
  • BD Pyxis Anesthesia System 4000,
  • BD Pyxis Anesthesia System 3500,
  • BD Pyxis MedStation 4000 T2,
  • BD Pyxis MedStation ES,
  • BD Pyxis SupplyStation,
  • BD Pyxis Supply Roller,
  • BD Pyxis ParAssist System,
  • BD Pyxis PARx,
  • BD Pyxis CIISafe ? Workstation,
  • BD Pyxis StockStation System, and
  • BD Pyxis Parx handheld

Descripción:

El investigador Mathy Vanhoef de imec-DistriNet, KU Leuven, descubrió las vulnerabilidades KRACK y BD ha avisado de su posible afectación. Un potencial atacante podría manipular los datos de tráfico, consiguiendo un descubrimiento parcial de comunicaciones cifradas o una inyección de tráfico.

Solución:

BD ha implementado parches de terceros a través de su rutina de despliegue de parches que resuelve esta vulnerabilidad en la mayoría de dispositivos. Algunos dispositivos requieren de coordinación con BD. BD está en contacto con los clientes para programar y desplegar los parches. Además, BD recomienda:

  • Asegurarse de que las últimas actualizaciones se encuentran instaladas en los puntos de acceso Wifi
  • Aplicar las medidas físicas apropiadas para prevenir los ataques que provienen del rango físico.
  • Asegurarse que se disponen de copias de respaldo de los datos y de procesos de recuperación ante desastres.

Detalle:

Existe una vulnerabilidad en el protocolo WPA y WPA2 usado en toda la industria, afectado por ataques de reinstalación de claves conocidos como KRACK (Key Reinstallation Attacks).

El tráfico de establecimiento en cuatro pasos usado en los protocolos Wi-Fi WPA y WPA2 se puede manipular para permitir la reutilización de nonce resultando en una reinstalación de la clave. Esto podría permitir a un potencial atacante dentro del alcance de la señal, ejecutar un ataque de hombre en el medio, reproducir, descifrar o falsificar tramas. Se han asignado los siguientes identificadores a esta vulnerabilidad: CVE-2017-13077, CVE-2017-13078, CVE-2017-13079, CVE-2017-13080, CVE-2017-13081, CVE-2017-13082, CVE-2017-13086, CVE-2017-13087 y CVE-2017-13088.

Etiquetas: Comunicaciones, Vulnerabilidad