Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Ejecución remota de código en Apache Struts 2

Fecha de publicación: 23/08/2018

Importancia: Crítica

Recursos afectados:

  • Desde Strtus 2.3 hasta Struts 2.3.34
  • Desde Struts 2.5 hasta Struts 2.5.16
  • Otras versiones no soportadas de Struts pueden verse igualmente afectadas

Descripción:

Una vulnerabilidad en Apache Struts podría permitir a un atacante remoto no autenticado, ejecutar código arbitrario en un sistema objetivo.

Solución:

Detalle:

  • Incorrecta validación de la entrada proporcionada por el usuario que podría permitir el uso de resultados sin valor de espacio de nombres y el uso de etiquetas url sin valor ni acción. En los casos en los que las acciones o configuraciones superiores no tengan espacio de nombres o de caracteres comodín, un atacante podría explotar esta vulnerabilidad enviando una solicitud que entregue entradas maliciosas a la aplicación afectada para su procesamiento. Si tiene éxito, el atacante podría ejecutar código arbitrario en el contexto de seguridad de la aplicación afectada en el sistema objetivo. Se ha reservado el código CVE-2018-11776 para esta vulnerabilidad de severidad crítica.

Etiquetas: Actualización, Apache, Vulnerabilidad