Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Ejecución remota de código en el gestor de paquetes APT

Fecha de publicación: 24/01/2019

Importancia: Alta

Recursos afectados:

  • Gestor de paquetes APT, versiones anteriores a la 1.4.9

Descripción:

El investigador de seguridad Max Justicz ha descubierto una vulnerabilidad que permite la ejecución remota de código en la utilidad apt-get del gestor de paquetes APT, usada por distribuciones basadas en Debian.

Solución:

  • Se podría evitar este tipo de ataque utilizando repositorios HTTPS por parte de APT, para ello es necesario instalar el paquete apt-transport-https.
  • Actualizar, con la mayor brevedad posible, a la versión 1.4.9 de APT.

Para evitar que la vulnerabilidad sea explotada al realizar estas acciones, si el paquete se redirige de forma predeterminada, será necesario elegir diferentes réplicas o descargar el paquete directamente. Las siguientes instrucciones para Debian y Ubuntu indican cómo hacerlo correctamente.

Detalle:

  • Los redireccionamientos HTTP de APT ayudan a las máquinas Linux a encontrar automáticamente el servidor espejo adecuado para descargar paquetes de software cuando otros no están disponibles, devolviendo una respuesta con la ubicación del siguiente servidor desde donde el cliente debe solicitar el paquete si el primer servidor falla de alguna manera. Esto puede permitir que un atacante, en un escenario de MitM (Man in the Middle), pueda inyectar contenido malicioso en los paquetes descargados por APT y engañar así al sistema para que instale paquetes alterados. Se ha reservado el identificador CVE-2019-3462 para esta vulnerabilidad.

Etiquetas: Actualización, Linux, Ubuntu, Vulnerabilidad