Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en IBM Db2

Fecha de publicación: 24/05/2018

Importancia: Alta

Recursos afectados:

  • Versiones IBM Db2 V9.7, V10.1, V10.5, y V11.1 en todas las plataformas.

Descripción:

Se han detectado múltiples vulnerabilidades de criticidad alta en IBM Db2 que podrían permitir a un atacante sin credenciales ejecutar código arbitrario, elevación de privilegios o comprometer los archivos locales.

Solución:

IBM ha puesto a disposición de los usuarios actualizaciones de seguridad que solucionan las vulnerabilidades en función de la versión afectada. Estas actualizaciones está disponibles en el siguiente enlace:

Fix Central

Detalle:

Las vulnerabilidades detectadas son:

  • Cuatro vulnerabilidades del tipo desbordamiento de búfer, donde un atacante local podría realizar una elevación de privilegios en la instancia DB2 en la que se encuentra. Se han reservado los identificadores CVE-2018-1450, CVE-2018-1544, CVE-2018-1515 y CVE-2018-1565 para estas vulnerabilidades.
  • Tres vulnerabilidad que podrían permitir a un atacante sobrescribir los archivos de la instancia DB2. Se han reservado los identificadores CVE-2018-1449, CVE-2018-1451 y CVE-2018-1452 para estas vulnerabilidades.
  • Una vulnerabilidad del tipo desbordamiento de búfer, donde un atacante local sin credenciales podría ejecutar código arbitrario. Se ha reservado el identificador CVE-2018-1488 para esta vulnerabilidad.
  • Una vulnerabilidad del tipo desbordamiento de búfer basado en pila causado por una mala gestión de los límites que podría permitir a un atacante ejecutar código arbitrario. Se ha reservado el identificador CVE-2018-1459 para esta vulnerabilidad.

Etiquetas: Actualización, IBM, Vulnerabilidad