Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en phpMyAdmin

Fecha de publicación: 28/01/2019

Importancia: Crítica

Recursos afectados:

Las siguientes versiones de phpMyAdmin se han visto afectadas:

  • Desde 4.0 hasta 4.8.4.
  • Desde 4.5.0 hasta 4.8.4.

Impacto:

El equipo de phpMyAdmin ha publicado la versión 4.8.5, que contiene varias correcciones de seguridad importantes.

Solución:

  • Se recomienda actualizar a la versión 4.8.5 o superior de phpMyAdmin.

Detalle:

  • En las versiones que van desde la 4.0 hasta la 4.8.4, cuando la configuración AllowArbitraryServer se le asigna el valor true en un servidor MySQL no autorizado, un atacante podría leer cualquier archivo del servidor al que el usuario tuviera acceso. Se ha asignado el identificador 2019-6799 para esta vulnerabilidad.
  • En las versiones que van desde la 4.5.0 hasta la 4.8.4, un atacante podría usar un nombre de usuario especialmente diseñado para iniciar un ataque de inyección SQL a través de la función designer. Se ha asignado el identificador CVE-2019-6798 para esta vulnerabilidad.

Etiquetas: Actualización, PHP, Vulnerabilidad