Basque Cyber Security Centre - Centro Vasco de Ciberseguridad

Múltiples vulnerabilidades en productos Cisco

Fecha de publicación: 14/05/2019

Importancia: Alta

Recursos afectados:

  • Dispositivos Cisco que utilicen una versión afectada del software Cisco IOS XE con la función de servidor HTTP activada. El estado predeterminado de la función Servidor HTTP depende de la versión.
  • La vulnerabilidad de modificación de hardware Cisco Secure Boot afecta a varios productos de Cisco que admiten la funcionalidad de arranque seguro basado en hardware, para ver el listado completo consulte la tabla de productos afectados en la sección de Referencias.

Descripción:

Cisco ha publicado dos vulnerabilidades, una en la interfaz de usuario basada en web (Web UI) de Cisco IOS XE Software que podría permitir a un atacante remoto autenticado ejecutar comandos en el shell Linux subyacente de un dispositivo afectado con privilegios de root, y otra en Secure Boot de Cisco, que podría permitir escribir una imagen de firmware modificada en el componente.

Solución:

Detalle:

  • El software afectado sanea incorrectamente la entrada suministrada por el usuario en la interfaz de usuario basada en web (Web UI) de Cisco IOS XE Software. Un atacante que tenga acceso de administrador a un dispositivo afectado podría explotar esta vulnerabilidad suministrando un parámetro de entrada, especialmente diseñado, en un formulario, en la interfaz de usuario de la Web y enviándolo posteriormente. Esto podría permitir al atacante ejecutar comandos arbitrarios en el dispositivo con privilegios de root, lo que puede llevar a un compromiso completo del sistema. Se ha asignado el identificador CVE-2019-1862 para esta vulnerabildad.
  • Una comprobación incorrecta en el área de código que gestiona las actualizaciones in situ de una parte de la implementación de hardware de arranque seguro de Field Programmable Gate Array (FPGA), podría permitir que un atacante con privilegios elevados y acceso al sistema operativo subyacente que se está ejecutando en el dispositivo afectado, escribiera una imagen de firmware modificada en la FPGA, causando que el dispositivo se vuelva inutilizable (y requerir un reemplazo de hardware) o manipulando el proceso de verificación de arranque seguro, lo que en algunas circunstancias puede permitir al atacante instalar y arrancar una imagen de software malicioso. Se ha asignado el identificador CVE-2019-1649 para esta vulnerabildad.

Etiquetas: Actualización, Cisco, Vulnerabilidad