Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Paketeen kudeaketa okerra Siemensen SIMATIC S7-400en

Argitalpen data: 2018/05/15

Garrantzia: Handia

Kaltetutako baliabideak:

  • SIMATIC S7-400, hardwarearen 4.0 eta lehenagoko bertsioduna, bertsio guztiak
  • SIMATIC S7-400, hardwarearen 5.0 bertsioduna, firmwarearen V5.2 bertsioa baino lehenagoko guztiak
  • SIMATIC S7-400H, hardwarearen 4.5 eta lehenagoko bertsioduna, bertsio guztiak

Azalpena:

Siemensek gaizki osatutako paketeen kudeaketa okerraren ahultasun bat aurkitu du SIMATIC S7-400 gailuetan. Kaltetutako produktuan erasotzaile batek zerbitzuaren ukapen egoera eragin lezake.

Konponbidea:

Siemensek erabiltzaile guztiei honako bertsioetara eguneratzea aholkatzen die:

  • SIMATIC S7-400, hardwarearen 4.0 eta lehenagoko bertsioduna: Hardwarearen 5.0 bertsiora eguneratzea, hemen eskuragarri: https://support.industry.siemens.com/cs/ww/en/view/109483507
  • SIMATIC S7-400, hardwarearen 5.0 bertsioduna: Firmwarearen V5.2 edo goragoko bertsiora eguneratzea, hemen eskuragarri: https://support.industry.siemens.com/cs/ww/en/view/109474827
  • SIMATIC S7-400H, hardwarearen 4.5 eta lehenagoko bertsioduna: Hardwarearen 6.0 bertsiora eguneratzea, hemen eskuragarri: https://support.industry.siemens.com/cs/ww/en/view/75407031

Xehetasuna:

Kaltetutako produktuek modu ezegokian baliozkotzen dituzte S7 komunikazio paketeak. Horrek zerbitzuaren ukapena eragin lezake, eta ondorioz eskuz berrabiarazi beharko litzateke. Erasotzaile batek bereziki gaizki osatutako S7 paketeak bidal litzake CPUaren komunikazio interfazera, Ethernet, PROFIBUS eta Multi Point Interfaces (MPI) interfazeetara barne. Ahultasun horretarako CVE-2018-4850 kodea erreserbatu da.

Etiketak: Eguneraketa, Siemens, Ahultasuna