Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun Rockwell Automation-en CompactLogix eta GuardLogix-en

Argitalpen data: 2019/02/05

Garrantzia: Handia

Kaltetutako baliabideak:

  • CompactLogix 5370 L1 kontrolatzaileak, 20tik 30.014ra bitarteko bertsioak eta lehenagokoak;
  • CompactLogix 5370 L2 kontrolatzaileak, 20tik 30.014ra bitarteko bertsioak eta lehenagokoak;
  • CompactLogix 5370 L3 kontrolatzaileak, 20tik 30.014ra bitarteko bertsioak eta lehenagokoak;
  • Compact GuardLogix 5370 kontrolatzaileak, 20tik 30.014ra bitarteko bertsioak eta lehenagokoak;
  • Armor Compact GuardLogix 5370 kontrolatzaileak, 20tik 30.014ra bitarteko bertsioak eta lehenagokoak.

Azalpena:

Nozomi Networks-eko Younes Dragoni eta CyberX-eko George Lashenko ikertzaileek baliabideen kontrol desegoki erako eta bufferraren gainezkatze erako ahultasunen berri eman dute Rockwell Automation-en CompactLogix eta GuardLogix produktuetan. Ahultasun horiek arrakastaz baliatuz gero urruneko erasotzaile batek web zerbitzarian zerbitzuaren ukapen egoera edo gailuetan akats ez berreskuragarria eragin litzake (MNRF, ingelesezko Major Non-Recoverable Fault).

Konponbidea:

  • Rockwell Automation-ek arren eskatzen die erabiltzaileei eskuragarri dauden azken partxeak aplikatzea gailuei, azken funtzionaltasunetan, akatsen zuzenketan eta segurtasun hobekuntzetan eguneratuta egoteko. Firmwarearen FRN 31.011 edo geroagoko bertsioetara eguneratzeak arindu egiten ditu ahultasun horiekin lotutako arriskuak.

Xehetasuna:

  • Baliabideen kontrol desegokia: urruneko erasotzaile batek bereziki diseinatutako HTTP/HTTPS pakete bat bidal dezake, bufferraren gainezkatze erako ahultasuna baliatzen duena, eta horrela urrunetik kodea exekutatzeko edo zerbitzaria egoera ez-eskuragarrian uzteko aukera eraginez. Behartutako berrabiatzea egin beharko litzateke, cold restart, sistema berreskuratzeko. Ahultasun horretarako CVE-2019-10952 identifikatzailea erabili da.
  • Bufferrak gainezka egitea: urruneko erasotzaile batek bereziki diseinatutako SNMP pakete bat bidal lezake zerbitzuaren ukapen egoera eragiteko. Horrek kontrolatzailea berreskuragarria ez den akats handiko egoera batean (MNRF) utziko luke. Ahultasun horretarako CVE-2019-10954 identifikatzailea erabili da.

Etiketak: Eguneraketa, Ahultasuna