Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun Hirschmann produktuen TCPdump funtzionaltasunetan

Argitalpen data: 2018/07/30

Garrantzia: Handia

Kaltetutako baliabideak:

  • HiOS, 07.0.00 bertsioa eta lehenagokoak ondorengo produktuetan:
    • RSP
    • RSPE
    • RSPS
    • RSPL
    • MSP
    • EES
    • EESX
    • GRS
    • OS
    • RED
  • Classic, ondoko produktuen bertsio guztiak:
    • RS
    • RSR
    • RSB
    • MACH100
    • MACH1000
    • MACH4000
    • MS
    • OCTOPUS
  • Cellular Router, 01.2.02 bertsioa eta lehenagokoak ondoko produktuan:
    • OWL

Azalpena:

Beldenek TCPdump funtzionaltasunen hainbat ahultasunen berri eman du Hirschmannen produktuen familia eta plataforma ezberdinetan. Bufferraren gainezkatzearen ahultasun hauek baliatuz urruneko erasotzaile batek zerbitzuaren ukapenak eragin litzake edo urrunetik kodea exekutatu.

Konponbidea:

Fabrikatzaileak bere bezeroei gomendatzen die produktuak lehenbailehen eguneratzea, posible den heinean behintzat.

  • HiOS: Produktu guztiak 07.0.01 bertsiora eguneratzea.
  • Classic: Produktu hauetarako ez da aurreikusten inolako eguneraketarik.
  • Cellular Router:
    • OWL LTE M12: 01.2.03 bertsiora eguneratzea.
    • OWL LTE, OWL 3G: Konponbidea 02.0.00 bertsiorako dago aurreikusita.

Xehetasuna:

TCPdumpen barnean (4.9.2 bertsioa baino lehenagokoak) sartuta dauden funtzioak egiten dituzten sarrera parametroen tratamendu okerra baliatuz, urruneko erasotzaile batek zerbitzuaren ukapenak eragin litzake edo kodea exekutatu.

Ahultasunak soilik balia daitezke saio aktibo batek bere jardunean zehar TCPdump funtzioak erabiltzen baditu eta sareko trafikoa kaltetutako gailuak zuzenean kudeatzen badu. TCPdump funtzionaltasuna berez inaktibo dago.

Ahultasun horietarako honako identifikatzaileak erabili dira: CVE-2017-12894, CVE-2017-12996, CVE-2017-12988, CVE-2017-13012, CVE-2017-13013, CVE-2017-13022, CVE-2017-13030, CVE-2017-13037, CVE-2016-7923, CVE-2016-7926, CVE-2016-7932, CVE-2016-7936, CVE-2016-7974, CVE-2016-7975, CVE-2016-7983, CVE-2016-7984.

Etiketak: Eguneraketa, Komunikazioak, Ahultasuna