Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun AVEVA produktuetan

Argitalpen data: 2018/08/01

Garrantzia: Kritikoa

Kaltetutako baliabideak:

  • Wonderware License Server, v4.0.13100 bertsioa eta lehenagokoak (Flexara Imgrd erabiltzen du, 11.13.1.1 eta lehenagoko bertsioak). Soilik Counted Licenses ezaugarria 'ArchestrAServer.lic'-ekin duten erabiltzaileak daude kaltetuta.
  • InTouch Access Anywhere 2017 Update 2 eta lehenagokoak. jQueryren bertsio ahulak 3.0.0 baino lehenagokoak dira.

Azalpena:

Googlen Security Team-ek eta ikertzaile anonimo batek hainbat ahultasun identifikatu dituzte AVEVA produktuetan. Sarbide datuen neutralizazio ezegokiaren erakoak eta memoriaren bufferraren mugetan murrizketa ezegokiaren erakoak dira. Erasotzaile batek informazio sentikorra eskura lezake, Javascript eta HTML kodea exekutatu edo urruneko kodea ere administratzaile pribilegioekin.

Konponbidea:

AVEVAk kaltetutako erabiltzaileei gomendatzen die 'InTouch Access Anywhere 2017 Update 2b' eta 'Hotfix Wonderware License Server VU-485744' partxeak edo ondorenekoak instalatzea, kaltetutako produktuaren arabera. Xehetasuna:

  • Memoriaren bufferraren mugetan murrizketa ezegokia. lmgrd-n bufferraren gainezkatzea eta Flexera FlexNet Publisher-en Vendor Daemon baliatuz urruneko erasotzaile batek kode arbitrarioa exekuta lezake manipulatutako pakete baten bidez, eta horrela urrunetik kodea exekuta liteke administratzaile pribilegioekin. Ahultasun horretarako CVE-2015-8277 identifikatzailea erabili da.
  • Web orria sortzean sarrera datuen neutralizazio desegokia (cross-site scripting): jQuery liburutegiak cross-site scripting (XSS) erasoak jasotzeko arriskua du domeinu gurutzatuko Ajax eskaera bat dataType aukera gabe egiten denean, eta horrek testu/javascript erako erantzunak exekutatzea eragiten du. Ahultasun horretarako CVE-2015-9251 identifikatzailea erabili da.
Etiketak: Eguneraketa, Ahultasuna