Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Múltiples vulnerabilidades en productos de Codesys V3

Fecha de publicación: 26/03/2020

Importancia: Crítica

Recursos afectados:

Todas las variantes de los siguientes productos CODESYS V3 en todas las versiones anteriores a V3.5.15.40 que contengan los componentes CmpRouter, CmpRouterEmbedded, CmpWevServer o CmpWebServerHandler:

  • CODESYS Control para BeagleBone,
  • CODESYS Control para emPC-A/iMX6,
  • CODESYS Control para IOT2000,
  • CODESYS Control para Linux,
  • CODESYS Control para PLCnext,
  • CODESYS Control para PFC100,
  • CODESYS Control para PFC200,
  • CODESYS Control para Raspberry Pi,
  • CODESYS Control RTE V3,
  • CODESYS Control RTE V3 (para Beckhoff CX),
  • CODESYS Control Win V3 (también parte de CODESYS Development System setup),
  • CODESYS Control V3 Runtime System Toolkit,
  • CODESYS V3 Embedded Target Visu Toolkit,
  • CODESYS V3 Remote Target Visu Toolkit,
  • CODESYS V3 Safety SIL2,
  • CODESYS Edge Gateway V3,
  • CODESYS Gateway V3,
  • CODESYS HMI V3,
  • CODESYS OPC Server V3,
  • CODESYS PLCHandler SDK,
  • CODESYS Control para BeagleBone,
  • CODESYS V3 Simulation Runtime (parte de CODESYS Development System).

Descripción:

El investigador Carl Hurd, de Cisco Talos, un cliente OEM y Tenable han reportado dos vulnerabilidades, una de severidad crítica y otra alta, que afectan a equipamiento de Codesys V3. Un atacante remoto podría generar una denegación de servicio o la ejecución de código arbitrario.

Solución:

3S-Smart Software Solutions GmbH ha publicado la versión V3.5.15.40 que soluciona dichas vulnerabilidades.

Detalle:

  • La vulnerabilidad de severidad crítica se debe a que el servidor web de Codesys es utilizado por WebVisu para mostrar pantallas de visualización en el navegador web. Peticiones especialmente creadas podrían causar un desbordamiento de búfer basado en memoria dinámica (heap), lo que podría resultar en un bloqueo en el navegador, pudiendo originar una condición de denegación de servicio o ejecutar código remoto. Se ha asignado el identificador CVE-2020-10245 para esta vulnerabilidad.
  • La vulnerabilidad de severidad alta se debe a que los productos de Codesys mencionados soportan un protocolo de routing para la comunicación entre clientes y el Codesys Control runtime. Paquetes de comunicación especialmente creados pueden desencadenar una lectura de búfer fuera de límites en la pila de comunicación, lo que podría generar una condición de denegación de servicio. Se ha asignado el identificador CVE-2019-5105 para esta vulnerabilidad.

Etiquetas: Actualización, Vulnerabilidad