Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun Optergy-ren Proton Enterprise Building Management System-en

Argitalpen data: 2019/06/07

Garrantzia: Kritikoa 

Kaltetutako baliabideak: 

  • Proton Enterprise, 2.3.0 eta lehenagoko bertsioak.

Azalpena: 

Applied Risk-eko Gjoko Krstic ikertzaileak Optergy-ren Proton Enterprise-ri eragiten dioten hainbat ahultasunen berri eman du: informazioaren hedapena, gune gurutzatuetan eskaeraren faltsutzeak (CSRF), fitxategi arriskutsuen murrizpenik gabeko igoera, asmo gaiztoko URLetara birbideratzea, ezkutuko funtzionaltasuna, metodo edo funtzio arriskutsua agerian uztea eta softwarean barneratutako kredentzialak. Horiek baliatuz erasotzaile batek kodea exekuta lezake urrunetik, sistemaren informazioa zabaldu eta sisteman sarbide osoa eskuratu.

Konponbidea:

  • Fabrikatzaileak gomendatzen duen konponbidea da Optergy zerbitzariak 2.4.5 bertsiora eguneratzea.

Xehetasuna:

  • Aplikazioaren erabiltzaile izena berrezartzeko funtzionaltasunaren bidez, erasotzaileak sisteman baliagarriak diren erabiltzaile guztiak zerrendatu eta agerian utz litzake, eta gainera sistemaren barneko informazioa zabal lezake. Ahultasun horietarako CVE-2019-7272 eta CVE-2019-7277 identifikatzaileak erabili dira.
  • Kargaren unean fitxategien luzapena baliozkotzen ez denez, autentifikaziorik gabeko urruneko erasotzaile batek baliozkotu gabeko luzapenak dituzten fitxategiak karga litzake, eta igoak izan diren direktorioaren barnean exekutatu. Ahultasun horretarako CVE-2019-7274 identifikatzailea erabili da.
  • Identifikatu gabeko backdoor baten bidez, erasotzaile batek sistemarako sarbidea eskura lezake eta kode arbitrarioa exekutatu. Ahultasun horretarako CVE-2019-7276 identifikatzailea erabili da.
  • Autentifikatu gabeko erabiltzaileek aitortu gabeko klaseen funtzioak erabil litzakete zenbait baliabidetara sarbidea lortzeko. Ahultasun horretarako CVE-2019-7278 identifikatzailea erabili da.
  • Erasotzaile batek softwarean barneratutako kredentzialak erabil litzake baimendu gabeko SMS mezuak bidaltzeko edozein telefono zenbakitara. Ahultasun horretarako CVE-2019-7279 identifikatzailea erabili da.
  • Gainerako ahultasunetarako honako identifikatzaileak esleitu dira: CVE-2019-7273 eta CVE-2019-7275.

Etiketak: Eguneraketa, Ahultasuna