Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun WAGO 852 Industrial Managed Switch-en

Argitalpen data: 2019/06/14

Garrantzia: Kritikoa

Kaltetutako baliabideak: 

  • 852-303, v1.2.2.S0 baino lehenagoko bertsioak
  • 852-1305,  v1.1.6.S0 baino lehenagoko bertsioak
  • 852-1505, v1.1.5.S0 baino lehenagoko bertsioak

Azalpena: 

SEC Consult Vulnerability Lab-eko T. Weber ikertzaileak hainbat ahultasun aurkitu ditu WAGO 852 switch industrialetan. Horien arrazoia da barneratutako firmware-ak ahulak diren liburutegiak eta software osagaiak erabiltzen dituela. Ahultasun horiek baliatuz erasotzaile batek gailura sartzea lor lezake firmwarean barneratutako kredentzialei eta gako pribatuei esker. Era berean bufferraren gainezkatzea balia lezake, eta kaltetutako gailuetan ezegonkortasuna eragin.

Konponbidea: 

Fabrikatzaileak erabiltzaileei gomendatzen die beren switcha eguneratzea eskuragarri dagoen firmwarearen azken bertsioarekin.

  • 852-303:  1.2.2.S0 bertsioa edo berriagoa.
  • 852-1305: 1.1.6.S0 bertsioa edo berriagoa.
  • 852-1505: 1.1.5.S0 bertsioa edo berriagoa.

Xehetasuna:

  • Kodetutako kredentzialetara sarbidea lukeen erasotzaile batek switcharen sistema eragilera sarbidea lortuko luke root pribilegioekin. Horri esker switcharen sistema eragilea manipula lezake. Ahultasun horretarako CVE-2019-12550 identifikatzailea erreserbatu da.
  • Kodetutako SSH gakora sarbidea lukeen erasotzaile batek komunikazioa eten lezake edo switcha arriskuan jarri. Erabiltzaileek ezin dituzte SSH gakoak berrezarri eta switch guztiek gako berdina erabiltzen dute. Ahultasun horretarako CVE-2019-12549 identifikatzailea erreserbatu da.
  • Hirugarrenen osagai ahulak: zerrendatutako produktuek ahultasun ezagunak dituzten hirugarrenen software osagaiak erabiltzen dituzte. Horiek arrakastaz baliatuz gero urruneko erasotzaile batek switcha arriskuan jar lezake edo bertan zerbitzuaren ukapen egoera eragin. Ahultasun horietako batzuen identifikatzaileak ondokoak dira, erabilitako liburutegi ahul bakoitzerako: 
    • BusyBox 1.12.0: CVE-2013-1813, CVE-2016-2148, CVE-2016-6301, CVE-2011-2716, CVE-2011-5325, CVE-2015-9261, CVE-2016-2147, CVE-2017-16544 etc.
    • GNU glibc 2.8: CVE-2010-0296, CVE-2010-3856, CVE-2012-4412, CVE-2014-4043, CVE-2014-9402, CVE-2014-9761, CVE-2014-9984, CVE-2015-14 etc.

Etiketak: Eguneraketa, Komunikazioak, Ahultasuna