Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

SAPen 2019ko iraileko segurtasun eguneraketa

Argitalpen data: 2019/09/11

Garrantzia: Kritikoa 

Kaltetutako baliabideak: 

  • SAP Business Client, 6.5 bertsioa;
  • SAP Business One Client, 9.2 eta 9.3 bertsioak;
  • SAP Business One, 9.3 bertsioa;
  • SAP BusinessObjects Business Intelligence Platform (CMC), 4.1, 4.2 eta 4.3 bertsioak;
  • SAP BusinessObjects Business Intelligence Platform, 4.1 eta 4.2 bertsioak;
  • SAP Diagnostic Agent (LM-Service), 7.20 bertsioa;
  • SAP HANA Extended Application Services, 1.0.118 baino lehenagoko bertsioak;
  • SAP HANA, 1.0 eta 2.0 bertsioak;
  • SAP Kernel (RFC), honako bertsioak: KRNL32NUC, KRNL32UC eta KRNL64NUC 7.21, 7.21EXT, 7.22, 7.22EXT, KRNL64UC 7.21, 7.21EXT, 7.22, 7.22EXT, 7.49, 7.73 eta KERNEL 7.21, 7.49, 7.53, 7.73, 7.76;
  • Java (Web Container)-ENGINEAPIrako SAP NetWeaver AS, 7.10, 7.20, 7.30, 7.31, 7.40 eta 7.50 bertsioak;
  • SAP NetWeaver Process Integration Runtime Workbench - MESSAGING eta SAP_XIA, 7.31, 7.40 eta 7.50 bertsioak;
  • SAP Supplier Relationship Management (Master Data Management Catalog) (SRM_MDM_CAT), 3.73, 7.31 eta 7.32 bertsioak.

Azalpena: 

SAPek hainbat produkturi buruzko segurtasun eguneraketa batzuk argitaratu ditu bere hileroko komunikatuan.

Konponbidea: 

SAPen zerbitzu ataria bisitatzea, eta fabrikatzaileak adierazten duen moduan beharrezkoak diren eguneraketa edo partxeak instalatzea.

Xehetasuna: 

SAPek segurtasun partxeei buruz argitaratzen duen hileroko komunikatuan 4 segurtasun ohar eta 3 eguneraketa eman ditu ezagutzera. Horietatik 4 larritasun kritikokoak dira, 1 larritasun altukoa, 7 larritasun ertainekoak eta 1 larritasun baxukoa.

Argitaratutako ahultasun motak honako hauek dira:

  • Sistema eragileko komandoen injekzio erako 2 ahultasun;
  • zerbitzuaren ukapen erako 2 ahultasun;
  • Cross-Site Scripting (XSS) erako 2 ahultasun;
  • pribilegioen eskalatze erako ahultasun bat;
  • kode injekzioko ahultasun bat;
  • beste era batzuetako 5 ahultasun.

Kritikotzat eta altutzat kalifikatutako segurtasun oharrak honi buruzkoak dira:

  • Erabiltzailearen sarreraren egiaztapenaren saiheste erako ahultasun bat. Erasotzaile batek kodea injekta lezake, web eduki dinamiko baten modukoa, eta komandoen baimenik gabeko exekuzioa eragin, informazio sentikorra ezagutzera eman edo zerbitzuaren ukapen egoera sortu. Ahultasun horretarako CVE-2019-0355 identifikatzailea erabili da.
  • 2018ko apirileko buletinaren eguneraketa bat.
  • 2019ko uztaileko buletinaren eguneraketa bat.
  • Autentifikatutako erasotzaile batek zerbitzuaren ukapen egoera eragin lezake. Ahultasun horretarako CVE-2019-0364 identifikatzailea erabili da.

Etiketak: Eguneraketa, SAP, Ahultasuna