Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Kodearen urruneko exekuzioa Apache Struts 2-n

Argitalpen data: 2018/08/23

Garrantzia: Kritikoa

Kaltetutako baliabideak:

  • Strtus 2.3tik Struts 2.3.34ra bitartean
  • Struts 2.5etik Struts 2.5.16ra bitartean
  • Euskarririk ez duten Strutsen beste bertsio batzuk ere kaltetu egin litezke

Azalpena:

Apache Strutsek duen ahultasun bat baliatuz, autentifikatu gabeko urruneko erasotzaile batek kode arbitrarioa exekuta lezake xede duen sisteman.

Konponbidea:

Xehetasuna:

  • Erabiltzaileak eskainitako sarreraren egiaztapen oker baten ondorioz, izenen zuriune baliorik gabeko emaitzak erabil litezke eta url etiketen erabilpena egin liteke baliorik eta ekintzarik gabe. Goi mailako ekintza edo konfigurazioek izenen zuriunerik edo komodin karaktererik ez duten kasuetan, erasotzaile batek ahultasun hori balia lezake kaltetutako aplikazioari sarrera gaiztoak emango dizkion eskari bat bidaliz, prozesa dezan. Arrakasta baldin badu, erasotzaileak kode arbitrarioa exekuta lezake xede sisteman kaltetutako aplikazioaren segurtasun testuinguruan. Larritasun kritikoko ahultasun horretarako CVE-2018-11776 identifikatzailea erreserbatu da.

Etiketak: Eguneraketa, Apache, Ahultasuna