Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun BIND-en

Argitalpen data: 2019/04/25

Garrantzia: Handia

Kaltetutako baliabideak:

  • BIND, 9.9.0tik 9.10.8-P1era bitarteko bertsioak, 9.11.0tik 9.11.6ra bitartekoak, 9.12.0tik 9.12.4ra bitartekoak eta 9.14.0.
  • BIND 9 Supported Preview Edition, 9.9.3-S1tik 9.11.5-S3ra bitarteko bertsioak eta 9.11.5-S5.9.13 garapen adarreko 9.13.0tik 9.13.7ra bitarteko bertsioak ere kaltetuta daude. BIND 9.9.0 baino lehenagoko bertsioak ez ditu ebaluatu CVE-2018-5743 ahultasunak.
  • BIND Supported Preview Edition, 9.10.5-S1etik 9.11.5-S5era bitarteko bertsioak.

Azalpena:

BINDek dituen hainbat ahultasunen berri argitaratu da, 1 larritasun altukoa eta 2 larritasun ertainekoak.

Konponbidea:

Kaltetutako bertsioaren arabera dagokion bertsiora eguneratzea.

  • BIND 9.11.5-S6
  • BIND 9.11.6-S1
  • BIND 9.11.6-P1
  • BIND 9.12.4-P1
  • BIND 9.14.1

Xehetasuna:

  • Diseinutik BINDek mugatu egiten du aldi berean konekta daitekeen TCP bezeroen kopurua. Parametro hori alda daiteke baina aldatzen ez den bitartean balio kontserbadorea dauka. Kodeak duen akats bat baliatuz, erasotzaile batek aldi bereko TCP konexioen kopurua mugaz gain handitu lezake. Horrela sareko konexioetarako eskuragarri dauden fitxategien deskribatzaileen multzoa agortzea eragin lezake. Ahultasun horretarako CVE-2018-5743 identifikatzailea erreserbatu da.

Gainerako ahultasunetarako ondoko identifikatzaileak erreserbatu dira: CVE-2019-6467 eta CVE-2019-6468.

Etiketak: Eguneraketa, Ahultasuna