Cookien konfigurazioa

Cookie teknikoak

Aktiboak
Ikusi Cookiak

Erabiltzaileari web-orriaren bidez nabigatzeko eta bertan dauden aukerak edo zerbitzuak erabiltzeko aukera ematen diotenak dira, editoreak web-orriaren kudeaketa eta operatiboa ahalbidetzeko eta haren funtzioak eta zerbitzuak gaitzeko erabiltzen dituenak barne.

Cookie analitikoak

Ez aktiboak
Ikusi Cookiak

Webgunearen erabiltzaileen portaeraren jarraipena eta azterketa egiteko aukera ematen diote horien arduradunari. Cookie mota horien bidez bildutako informazioa webgunearen jarduera neurtzeko erabiltzen da, zerbitzuaren erabiltzaileek egiten dituzten erabilera-datuen analisiaren arabera hobekuntzak sartzeko

COOKIE OHARRA

SPRIren jabetzako web orri honek bere cookieak eta hirugarrengoenak erabiltzen ditu nabigatzea ahalbidetzeko, informazio estatistikoa osatzeko, zure nabigazio-ohiturak aztertzeko eta horien araberako publizitatea zuri igortzeko xedez. Cookie guztien erabilera baimentzeko, Onartu aukeran klik egin dezakezu; bestela, zein cookie-mota onartu eta zeini uko egingo diozun hauta dezakezu Cookieak Konfiguratu aukeraren bitartez. Halaber, informazio gehiago jaso dezakezu gure Cookie Politikan.Cookieak KonfiguratuOnartu

Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun Jenkins-en

Argitalpen data: 2018/09/26

Garrantzia: Handia

Kaltetutako baliabideak:

  • Arachni Scanner Plugin, 0.9.7 eta lehenagoko bertsioak.
  • Argus Notifier Plugin, 1.0.1 eta lehenagoko bertsioak.
  • Artifactory Plugin, 2.16.1 eta lehenagoko bertsioak.
  • Chatter Notifier Plugin, 2.0.4 eta lehenagoko bertsioak.
  • Config File Provider Plugin, 3.1 eta lehenagoko bertsioak.
  • Crowd 2 Integration Plugin, 2.0.0 eta lehenagoko bertsioak.
  • Dimensions Plugin, 0.8.14 eta lehenagoko bertsioak.
  • Email Extension Template Plugin, 1.0 eta lehenagoko bertsioak.
  • Git Changelog Plugin, 2.6 eta lehenagoko bertsioak.
  • HipChat Plugin, 2.2.0 eta lehenagoko bertsioak.
  • JIRA Plugin, 3.0.1 eta lehenagoko bertsioak.
  • Job Configuration History Plugin, 2.18 eta lehenagoko bertsioak.
  • JUnit Plugin, 1.25 eta lehenagoko bertsioak.
  • mesos Plugin, 0.17.1 eta lehenagoko bertsioak.
  • Metadata Plugin, 1.1.0b eta lehenagoko bertsioak.
  • Monitoring Plugin, 1.73.1 eta lehenagoko bertsioak.
  • MQ Notifier Plugin, 1.2.6 eta lehenagoko bertsioak.
  • PAM Authentication Plugin, 1.3 eta lehenagoko bertsioak.
  • Publish Over Dropbox Plugin, 1.2.4 eta lehenagoko bertsioak.
  • Rebuilder Plugin, 1.28 eta lehenagoko bertsioak.
  • SonarQube Scanner Plugin, 2.8 eta lehenagoko bertsioak.

Azalpena:

Jenkins proiektuen automatizazio eta hedatze softwarean dauden hainbat ahultasunen berri eman da. Urruneko erasotzaile batek ahultasun horiek balia litzake hainbat eratako erasoak egiteko: gune gurutzatuetan eskaeraren faltsutzea (CSRF), kode gaiztoaren injekzioa (XSS) bai iraunkorra eta bai islatua, pribilegiorik gabeko erabiltzaileen aldetik kredentzialen zerrendatzea, eskarien faltsutzea zerbitzariaren aldean (SSRF), testu lauan gordetako kredentzialak eskuratzea edo kontuetara sartzea balioztatze egokirik gabe.

Konponbidea:

  • Arachni Scanner Plugin 1.0.0 bertsiora eguneratu beharra dago.
  • Argus Notifier Plugin 1.0.2 bertsiora eguneratu beharra dago.
  • Artifactory Plugin 2.16.2 bertsiora eguneratu beharra dago.
  • Chatter Notifier Plugin 2.0.5 bertsiora eguneratu beharra dago.
  • Config File Provider Plugin 3.2 bertsiora eguneratu beharra dago.
  • Crowd 2 Integration Plugin 2.0.1 bertsiora eguneratu beharra dago.
  • Dimensions Plugin 0.8.15 bertsiora eguneratu beharra dago.
  • Email Extension Template Plugin 1.1 bertsiora eguneratu beharra dago.
  • Git Changelog Plugin 2.7 bertsiora eguneratu beharra dago.
  • HipChat Plugin 2.2.1 bertsiora eguneratu beharra dago.
  • JIRA Plugin 3.0.2 bertsiora eguneratu beharra dago.
  • Job Configuration History Plugin 2.18.1 bertsiora eguneratu beharra dago.
  • JUnit Plugin 1.26 bertsiora eguneratu beharra dago.
  • mesos Plugin 0.18 bertsiora eguneratu beharra dago.
  • Metadata Plugin-ek oraindik ez du eskuragarri fix-ik.
  • Monitoring Plugin 1.74.0 bertsiora eguneratu beharra dago.
  • MQ Notifier Plugin 1.2.7 bertsiora eguneratu beharra dago.
  • PAM Authentication Plugin 1.4 bertsiora eguneratu beharra dago.
  • Publish Over Dropbox Plugin 1.2.5 bertsiora eguneratu beharra dago.
  • Rebuilder Plugin 1.29 bertsiora eguneratu beharra dago.
  • SonarQube Scanner Plugin 2.8.1 bertsiora eguneratu beharra dago.

Xehetasuna:

Ahultasun guztien artetik, soilik ondokoa da kritikotasun altukoa:

  • SECURITY-1156: Monitoring Plugin-eko JavaMelody liburutegiak XML External Entity-ren (XXE) prozesamendu erako ahultasun bat dauka. Hori baliatuz erasotzaile batek eskaera landuak bidal ditzake web aplikazio batera, fitxategien sistemaren informazioa eskuratzeko, zerbitzariaren aldean eskaerak faltsutzeko (SSRF) edo zerbitzuaren ukapen erasoak egiteko (DoS). Ahultasun horretarako CVE-2018-15531 identifikatzailea erreserbatu da.

Kritikotasun ertain eta baxuko beste ahultasun batzuk ere argitaratu dira, honako identifikatzaile hauekin: SECURITY-130, SECURITY-265, SECURITY-813 (CVE-2017-12197), SECURITY-845, SECURITY-938, SECURITY-948, SECURITY-972, SECURITY-984 (2), SECURITY-1011 (2), SECURITY-1013 (2), SECURITY-1029, SECURITY-1050 (2), SECURITY-1065, SECURITY-1067, SECURITY-1068, SECURITY-1075, SECURITY-1080, SECURITY-1101, SECURITY-1108, SECURITY-1122, SECURITY-1125, SECURITY-1130, SECURITY-1135, eta SECURITY-1163.

Etiketak: Eguneraketa, Ahultasuna