Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun Jenkins-en

Argitalpen data: 2018/12/07

Garrantzia: Kritikoa

Kaltetutako baliabideak:

  • Jenkins Weekly, 2.153 eta lehenagoko bertsioak.
  • Jenkins LTS, 2.138.3 eta lehenagoko bertsioak.

Azalpena:

Jenkinsek hainbat produkturi buruzko 4 ahultasun argitaratu ditu, horietatik 1 larritasun kritikokoa eta 3 larritasun ertainekoak.

Konponbidea:

Xehetasuna:

Ondoren larritasun kritikoko ahultasuna soilik zehazten da, SECURITY-595 identifikatzailea duena.

  • HTTP eskaerak maneiatzeko, Jenkins-ek Stapler web framework-a erabiltzen du eta honek bere nomenklaturaren konbentzioekin bat datozen kode elementuetarako sarbide erreflexiboa erabiltzen du. Horiek oso estuki bat datozenez Javan ohikoak diren kode patroiekin, diseinatutako URLetarako sarbideak metodo batzuk dei litzake inoiz modu horretara deitu nahiko ez zirenak. Horren ondorioz:
    • Autentifikaziorik gabeko erabiltzaileek saio guztiak baliogabetu litzakete Jenkins exekutatzen dutenean Winstone-Jetty zerbitzaria integraturik.
    • Overall/Read baimena duten erabiltzaileek memorian erabiltzailearen objektu berriak sor litzakete.
    • Overall/Read baimena duten erabiltzaileek AsyncPeriodicWork inplementazioen exekuzioak eskuz has litzakete, bestela aldizka exekutatuko liratekeenak.

Gainerako ahultasunetarako Jenkins-ek honako identifikatzaileak erabili ditu: SECURITY-904, SECURITY-1072 eta SECURITY-1193

Etiketak: Eguneraketa, Ahultasuna