Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun Moodle-n

Argitalpen data: 2018/09/17

Garrantzia: Handia

Kaltetutako baliabideak:

Ondoko bertsioak izan dira kaltetuak, ahultasunen arabera:

  • MSA-18-0019: 3.5etik 3.5.1era bitartekoak, 3.4tik 3.4.4ra bitartekoak, 3.3tik 3.3.7ra bitartekoak, eta zerbitzurik gabeko lehenagoko bertsioak.
  • MSA-18-0018: 3.5etik 3.5.1era bitartekoak, 3.4tik 3.4.4ra bitartekoak, 3.3tik 3.3.7ra bitartekoak, 3.1etik 3.1.13ra bitartekoak eta zerbitzurik gabeko lehenagoko bertsioak.
  • MSA-18-0017: 3.5etik 3.5.1era bitartekoak, 3.4tik 3.4.4ra bitartekoak, 3.1etik 3.1.13ra bitartekoak, eta zerbitzurik gabeko lehenagoko bertsioak.

Azalpena:

Moodlen 3 ahultasun aurkitu dira, bat kritikotasun altukoa eta beste bi kritikotasun baxukoak. Ahultasun horiek XSS islatu bat (edo zeharkakoa) edo PHP kodearen injekzioa eta exekuzioa eragin lezakete. Gainera, hirugarrenen liburutegi bat eguneratu da zuhurtziazko neurri modura.

Konponbidea:

Erabiltzaileen eskura jarri dira ondoko eguneraketak, ahultasun bakoitzaren arabera:

  • MSA-18-0019: 3.5.2, 3.4.5 eta 3.3.8.
  • MSA-18-0018 eta MSA-18-0017: 3.5.2, 3.4.5, 3.3.8 eta 3.1.14.

Xehetasuna:

Kritikotasun altuko ahultasuna ondokoa da:

  • Drag and drop into text metodoarekin heredatutako frogazko galderak inportatzean, erasotzaile batek PHP kodea injekta eta exekuta lezake inportatutako galderetan, bai nahita edo bai iturri ez fidagarri batetik galderak inportatuz.

Ahultasun horietarako honako identifikatzaileak erreserbatu dira: CVE-2018-14631 (MSA-18-0019), CVE-2018-1999022 (MSA-18-0018) eta CVE-2018-14630 (MSA-18-0017).

Etiketak: Eguneraketa, Edukien kudeatzailea, Ahultasuna