Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Hainbat ahultasun PuTTYn

Argitalpen data: 2019/03/25

Garrantzia: Kritikoa

Kaltetutako baliabideak:

  • 0.70 eta lehenagoko bertsioak

Azalpena:

PuTTYk hainbat ahultasunen berri eman du, horietatik 3 larritasun kritikokoak.

Konponbidea:

Xehetasuna:

Larritasun kritikoko ahultasunak honakoak dira:

  • Unix PuTTYk select(2) erabiltzen du Unix fitxategien deskriptoreak ikusteko, mugarik gabeko fd_set motako aldagai bat baitute. 1024ko luzerako edo hori baino luzeagoko fitxategi batekin aurkituko balitz fd_set-en, monitorea ez litzateke gai izango fitxategi hori monitorizatzeko, eta bufferraren gainezkatzea gertatuko litzateke. Ahultasun horretarako CVE-2019-9895 identifikatzailea erabili da.
  • Erabiltzaile batek PuTTYren interfaze grafikoaren tresnen markoan online laguntza exekutatzen duenean, softwarea saiatzen da bere laguntza fitxategia bilatzen bere exekutagarriarekin batera. Portaera horrek ahalbidetuko luke, hain zuzen ere, erasotzaile batek biktima engainatzea, bezeroan asmo gaiztoko kodea exekuta dezan CHM fitxategiaren bahiketaren bidez. Ahultasun horretarako CVE-2019-9896 identifikatzailea erabili da.
  • PuTTYk zenbaki kriptografiko erdi-ausazkoak sortzeko duen moduan akatsa dago, eta batzuetan ematen du birritan erabiltzen duela zenbaki erdi-ausazkoen multzo berdina. Ahultasun horretarako CVE-2019-9898 identifikatzailea erabili da.

Gainerako ahultasunak honakoak dira:

  • Kodearen exekuzioa CHM hijacking bidez.
  • Integer Overflow erako ahultasuna. Ahultasun horretarako CVE-2019-9894 identifikatzailea erabili da.
  • Zerbitzuaren ukapena. Ahultasun horretarako CVE-2019-9897 identifikatzailea erabili da.

Etiketak: Eguneraketa, Komunikazioak, Ahultasuna