Hainbat ahultasun Tableau Desktop-en

Argitalpen data: 2019/03/27

Garrantzia: Handia

Kaltetutako baliabideak:

  • Tableau Desktop, Mac eta Windows sistema eragileetarako:  
    • 10.1etik 10.1.22 bertsiora
    • 10.2tik 10.2.18 bertsiora
    • 10.3tik 10.3.18 bertsiora
    • 10.4tik 10.4.14 bertsiora
    • 10.5etik 10.5.13 bertsiora
    • 2018.1etik 2018.1.10 bertsiora
    • 2018.2tik 2018.2.7 bertsiora
    • 2018.3tik 2018.3.4 bertsiora
    • 2019.1etik 2019.1.0 bertsiora (Tableau Server-en 2019.1.1 bertsioa geldiarazi egin zen)
    • 2019.1etik 2019.1.1 bertsiora

Azalpena:

Tableau-k Tableau Desktop-i eragiten dioten hiru ahultasunen berri eman du. Horiek baliatuz kodea urrunetik exekuta liteke eta datuak erakutsi baimenik gabeko erabiltzaileei. 

Konponbidea:

  • Tableau Desktop-ek ahultasun horiek arintzen dituzten hainbat eguneraketa argitaratu ditu, bertsioaren eta sistema eragilearen arabera. Bertsioa ondorengo zerrendan ikus daiteke: 
    • 10.1.23 bertsioa
    • 10.2.19 bertsioa
    • 10.3.19 bertsioa
    • 10.4.15 bertsioa
    • 10.5.14 bertsioa
    • 2018.1.11 bertsioa
    • 2018.2.8 bertsioa
    • 2018.3.5 bertsioa
    • 2019.1.2 bertsioa

Xehetasuna:

  • Ahultasun batek informazioa thumbnail-etan (irudi txikiak) erakustea ahalbidetzen du. Lan liburu batean horiek ikus ditzakeen erabiltzaile batek horren irudi estatiko bat ikusi ahal izango du, argitaratu zen unean zen bezalakoa. Irudi horrek izan litzake erabiltzaile "ikusleak" ikusi beharko ez lituzkeen irudiak.
  • Mac-en Tableau Desktop-en bidez asmo gaiztoko Web Datuen Konektore batera konektatzen den erabiltzaile batek memoriaren hondatze erako ahultasuna eragin lezake. Ahultasun hori baliatuko lukeen erasotzaile batek kode arbitrarioa exekuta lezake edo blokeo bat eragin.
  • Webgune batean autentifikatzeko NTLM protokoloa erabiltzen denean, mugez kanpoko irakurketa eta idazketa gerta litezke. Horrek kodea urrunetik exekutatzea edo blokeo bat gertatzea eragin lezake. Tableau Server-en asmo gaiztoko liburu bat irekitzeak edo asmo gaiztoko instantzia batera konektatzeak ahultasun hori eragin dezakete. Ahultasun hori "libcurl" liburutegiarekin lotuta dago eta CVE-2018-16890 eta CVE-2019-3822 identifikatzaileak esleitu zaizkio.

Etiketak: Eguneraketa, Ahultasuna