Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Ahultasuna TP-Link-en EAP softwarean

Argitalpen data: 2018/09/27

Garrantzia: Handia

Kaltetutako baliabideak:

  • EAP Controller, 2.5.3 eta lehenagoko bertsioak.

Azalpena:

TP-Link EAP kontrolatzaileak ez dauka RMI autentifikaziorik eta deserializazio erasoek kaltetu egin dezakete.

Konponbidea:

Une honetan EAP kontrolatzailearentzat ez dago ahultasuna osorik konpontzen duen eguneraketarik eskuragarri. Nolanahi ere, TP-Linkek gomendatzen du hainbat neurri hartzea arriskua arintzen eta murrizten laguntzeko.

  • Apache Commons Collections eguneratzea
  • EAPren JRE azken bertsiora eguneratzea

Xehetasuna:

Linuxerako TP-Link EAP sotwareak, haririk gabeko sarbide puntuko (WAP) gailuak urrunetik kontrolatzea ahalbidetzen duena, ez dauka erabiltzaile autentifikaziorik RMI zerbitzuko komandoetarako. Gainera, Apache Commons Collections-en bertsio zaharkitu eta ahul bat erabiltzen du. Urruneko erasotzaile batek deserializazio erasoak egin litzake RMI protokoloaren bidez, EAP Controller zerbitzaria urrunetik kontrola lezake eta Java edo bytecode Java funtzioak exekuta litzake. Apache Commons Collections ahultasunerako CVE-2015-6420 identifikatzailea erabili da. Eta EAP kontrolatzailearen ahultasunerako CVE-2018-5393 identifikatzailea erreserbatu da.

Etiketak: Eguneraketa, Apache, Komunikazioak, Java, Ahultasuna