Basque Cyber Security Centre - Zibersegurtasun Euskal Zentroa

Ahultasuna F5en hainbat produktutan

Argitalpen data: 2018/12/17

Garrantzia: Handia

Kaltetutako baliabideak:

  • BIG-IP (LTM, AAM, AFM, Analytics, APM, ASM, DNS, Edge Gateway, FPS, GTM, Link Controller, PEM, WebAccelerator)
    • 14.0.0tik 14.1.0ra bitarteko bertsioak
    • 13.1.0tik 13.1.1era bitarteko bertsioak
  • BIG-IQ Centralized Management
    • 6.0.0tik 6.0.1era bitarteko bertsioak
    • 5.2.0tik 5.4.0ra bitarteko bertsioak

Azalpena:

Urruneko erasotzaile batek ordenagailu bat konekta lezake arazketa atakara eta JavaScript arbitrario bat exekutatu.

Konponbidea:

  • BIG-IQ Centralized Management-en kasuan, 6.0.0tik 6.0.1era bitarteko bertsioak, 6.1.0 bertsiora eguneratu.
  • Gainerako produktu eta bertsioen kasuan oraingoz ez da eguneraketarik argitaratu. Ahultasun hau nola arindu F5en orrialdean ikus daiteke, Erreferentziak atalean argitaratuta dago.

Xehetasuna:

  • F5en iRulesLX osagaiak erabiltzen duen Node.js-ri eragiten dion ahultasun bat baliatuz (6.15.0 baino lehenagoko bertsioak), edozein interfazetan modu lehenetsian arazteko erabiltzen den 5858 atakara konekta liteke urruneko erasotzaile bat eta JavaScript arbitrarioa exekuta lezake. Ahultasun horretarako CVE-2018-12120 identifikatzailea erabili da.
Etiketak: Eguneraketa, Ahultasuna